Saturday, 4 August 2012

Magnetic Scrolls Interpreter on RPi

Magnetic Scrolls adventure games can be played on a variety of platforms using the Magnetic interpreter. Here's how I got it running on the RPi.

Prerequisites

We need the Magnetic source from here. The GTK version seems like the best to run under LXDE, so we also need the GTK 2.0 development files.
$ sudo apt-get install libgtk2.0-dev

Building

Create a directory called Magnetic and unzip the source into it.
$ mkdir Magnetic
$ cd Magnetic
$ unzip ~/Downloads/Magnetic23Src.zip
There were a couple of tweaks necessary to get it to build. Firstly, there's a typo in Gtk/main.c at the end of line 307.
...(type8s *) hints_filename), NULL)
Should be:
...(type8s *) hints_filename, NULL))
I also edited the Makefile as I don't have the sound libraries installed. It now reads:
# SOUND_SYSTEM = SMPEG
# SOUND_SYSTEM = SDL_MIXER
# SOUND_SYSTEM = XMMS
SOUND_SYSTEM = NONE
Then you just need to build the Gtk directory.
$ cd Gtk
$ make
If everything works you should have a binary called gtkmagnetic.

Running

After building, just run:
$ gtkmagnetic&
The games can all be downloaded here. Just unzip them somewhere and load them via the GUI.

1 comment:

  1. Works great, but what dev pakages are needed for sound to work?

    ReplyDelete